Monthly Archives: março 2016

l2vpn-tutorial PDF para download muito detalhado

Em inglês pessoal, mas se você pensa em trabalhar com redes pense já em no minimo inglês técnico abs!waris-l2vpn-tutorial

Tutorial básico sobre VPNs de Camada 2 (L2VPN)

tux_cisco

Replicado do blog ccna postado e 2010, isso por incrível que pareça continua bem atual e usado, boa leitura pessoal.

 

Muitos aqui já ouviram falar de VPNs, imagino eu. VPN é o acrônimo para “Redes Privadas Virtuais”, ou seja, um modo de simular redes privadas em cima de uma rede… bem… não privada 😉 ! Redes não privadas podem ser backbones de provedores de serviço (como Telefonica ou Embratel), ou mesmo a Internet. As VPNs mais comuns são as de camada 3, ou seja, fazer com que dois elementos de rede pensem estar diretamente conectados via um link L3, ainda que existam “n” elementos no meio do caminho. Exemplos de VPN L3 podem ser Cisco DMVPN e túneis GRE.

Mas este post não é para tratar de VPNs L3, mas sim VPNs L2, algo que ainda não discutimos aqui.

O que são e para que servem L2VPNs?

Na verdade, L2 VPNs já existem há um bom tempo. Exemplo são redes Frame-Relay e ATM. Mas a “novidade” são as VPNs L2 estabelecidas sobre redes de camadas superiores, como IP ou MPLS. É sobre isso que falaremos neste post. Sob este prisma, portanto, L2VPNs são conexões ponto-a-ponto que simulam um circuito físico de camada 2. Podem ser usadas para trunks Ethernet entre switches localizados em zonas geográficas distintas, por exemplo, ou para transportar conexões L2 tradicionais (ex: Frame-Relay, ATM ou TDM) sobre redes MPLS ou IP.

E qual a vantagem disso?

A vantagem é a total transparência do “tubo” virtual formado entre as duas pontas, permitindo que qualquer protocolo (e não apenas IP) possa atravessá-lo. Podemos, por exemplo, conectar duas pontas Frame-Relay por meio de uma rede MPLS ou IP pura, algo que pode ajudar na transição – em grande operadoras – do mundo legado (FR e ATM) para IP, por exemplo. Também pode-se usar esta tecnologia para estender redes LAN Ethernet de uma ponta a outra, atravessando inúmeros elementos IP de forma completamente transparente – como no exemplo mencionado, em que um trunk Ethernet poderia ser estabelecido entre as duas pontas – algo inviável em VPNs L3.

Existem hoje tecnologias bastante difundidas que permitem isso: AToM (Any Transport over MPLS), L2TPv3 (Layer-2 Tunneling Protocol version 3), VPLS (Virtual Private LAN Services) – este último sendo uma forma de AToM. Ainda não tive tempo para procurar uma imagem IOS para 7200 que suporte AToM, apesar de eu ter quase certeza que exista uma. Em encontrando uma, seria possível subir um LAB no GNS-3 sobre o assunto 😉 !

Sobre a tecnologia, vamos focar aqui no AToM. Basicamente, o túnel formado entre duas pontas que permite a comunicação L2 de forma transparente é chamada de “pseudowire”, ou seja, um “fio virtual”. É o pseudowire, portanto, que emula uma conexão L2 entre duas (ou mais) pontas. A topologia abaixo ilustra o conceito:

tutorial.gif

Os roteadores ilustrados seriam os PEs da operadora, e estes rodam MPLS. Pseudowires usam LDP (Label Distribution Protocol) como protocolo de sinalização para sua formação. O processo passo-a-passo é ilustrado abaixo:

aprovisionamentoatom.jpg

Em termos de configuração, é bastante simples… basta seguir os passos abaixo:

1) Entre os roteadores envolvidos no caminho físico, MPLS deve estar ativado e LDPs devem ser trocados. Para que isso ocorra, os roteadores devem estabelecer uma relação de vizinhança entre eles (neighbors LDP).

2) Pelo menos o IP de origem e o de destino do pseudowire deve estar visível entre os 2 PEs participantes, isso é, os IPs usados devem constar nas tabelas de roteamento dos roteadores envolvidos no cenário.

3) A configuração do pseudowire é feita via o comando “xconnect” nos dois PEs envolvidos.

Basicamente, seria isso. No cenário apresentado na figura 01, portanto, a configuração ficaria da seguinte forma:

PE1:

PE2:

E para verificar:

Notem que o VCID (50 no caso) deve ser o mesmo em ambas as pontas.

Para colocar em prática, basta verificar a tabela ARP dos PCs:

Notem que, o fato do MAC ADDRESS do PC2 aparecer na tabela ARP do PC1 indica que PC1 enxerga PC2 como se estivesse diretamente conectado ao mesmo, via cabo Ethernet. Neste exemplo, emulamos uma conexão L2 Ethernet ponto-a-ponto, portanto.

Obviamente existe muito mais por trás desta tecnologia, e muito mais formas de se implementa-la. O objetivo deste post foi apenas dar um gostinho para vocês do que é possível se fazer em termos de VPN L2. Se conseguirem fazer testes, façam! Nada melhor que praticar para se aprender. Nos comments deste post vocês encontrarão o link para o IOS para a linha 7200 com suporte a pseudowires. E abaixo segue o link para botar ele para funcionar no GNS-3:

pwire.zip

Portanto… mãos a obra!!!

Abraço!

Marco Filippetti

Fonte consultada: http://www.sanog.org/resources/sanog7/waris-l2vpn-tutorial.pdf

VPN – L3VPN sobre L2TPv3 sem MPLS

tux_cisco

1      L3VPN em L2TP sem MPLS

A funcionalidade MPLS VPNs over IP Tunnels permite que seja configurado o serviço de VPN L3 sobre o backbone IP usando a tecnologia de túnel L2TPv3 multiponto ao invés do Multiprotocol Label Switching (MPLS). Como os tuneis multiponto suportam multiplos endpoints, é necessário configurar apenas um único tunnel em cada roteador PE.

1.1       Divulgação do Túnel pelo BGP entre os PEs

O Border Gateway Protocol (BGP) é utilizado para divulger os endpoints dos túneis e a subaddress family indentifier (SAFI) Essa feature introduz o tunnel SAFI e o atributo BGP SAFI-Specific Attribute (SSA). O tunnel SAFI define o endpoint do tunnel e transporta o endereço IPv4 e o nexthop do endpoint. O SAFI é identificado pelo SAFI number 64. O BGP SSA transporta o BGP preference e BGP flags, além de tunnel cookie, tunnel cookie length, e o session ID. Esses atributos permitem que o BGP distribua as informações de encapsulamento do túnel entre os roteadores PEs. O tráfego de VPNv4 é roteado através desses túneis. O next hop anunciado nos updates do BGP-VPNv4 determina qual túnel deverá ser usado para rotear o trafego..

1.2       Configurando os PEs

Um único tunnel L2TPv3 multiponto é configurado em cada PE. A VPN é criada configurando a instancia VRF normalmente. O túnel que transporta o tráfego da VPN através do backbone reside no seu proprio espaço de Endereçamento. Uma VRF chamada Resolve in VRF (RiV) é criada para gerenciar os endereçamentos do túnel. O endereçamento configurado na VRF RiV é associada com o tunnel e uma rota estática é configurada na VRF RiV para rotear o tráfego pelo túnel.
How to Configure MPLS VPNs over IP Tunnels
Para configurar o serviço de VPN L3 sobre o tunnel L2TPv3 multiponto deve-se crier a instancia VRF, criar o tunnel multiponto L2TPv3, redirecionar o tráfego Ip da VPN para o tunnel e configurar a troca de informações de VPN pelo BGP VPNv4.
 

Cenário

1.3       Objetivo

Cinco roteadores (CE1, PE1, P, PE2 e CE2) são conectados formando um backbone com 3 roteadores e dois CEs conectados. Pede-se:
•      O protocolo de roteamento de backbone PE1-P-PE2 deverá ser o OSPF na área 0 com todas as interfaces divulgadas e com mBGP no AS 1 entre os PEs para tráfego de VRFs;
•      Tanto o CE1 quanto o CE2 deverão pertencer a VRF VPN_A e deverá existir conectividade entre esses CEs;
•      Não deverá ser usado MPLS para o tráfego de dados da VRF. Deve-se usar um túnel L3VPN com L2TP;
•      O túnel deverá ter autenticação com a chave “12”.

1.4       Topologia

dl3vpn-l2tpv3
Figure-01:         Topologia

1.5       IOS utilizados

•      CE1, PE1, P, PE2 e CE2 – c7200-k91p-mz.122-25.S15.bin

1.6       Configuração dos Roteadores

1.6.1        Configurações do OSPF do Backbone

Em todos os roteadores configura-se o roteamento OSPF pelo comando “router ospf ” onde o “processo” é um numero do processo OSPF. O roteador também possui um router ID único que geralmente é a interface loopback ou então o maior endereço IP do roteador.
Para adicionar interfaces deve-se usar o comando “network

área ”. Um roteador pode ter interfaces em áreas distintas, define-se cada área pelo comando network e o tipo da área com o comando “area [type]”.

1.6.2        Configuração do MBGP

Para estabelecer uma VPN, seja lite ou não, é necessário configurar o MBGP para a troca de informações de prefixos de VPN. É necessário somente configurar o MBGP nos roteadores PEs da rede que possuem conexão com os CEs, ou seja, conectados diretamente aos sites.
O MBGP funciona como o BGP, configura-se em todos os roteadores pelo comando “router bgp ” onde o “AS” é o Autonomous System do backbone. Dentro da configuração de BGP adicionam-se os vizinhos estaticamente com o comando “neighbor remote-as ”.
Adiciona-se o IP da interface loopback como Router-ID pelo comando “bgp router-id ”.
Como os roteadores dentro do mesmo AS não divulgarão as rotas IBGP entre eles, faz-se o full-mesh de conexão MBGP ou configuram-se os roteadores centrais como Router-reflectors adicionando os demais roteadores como clientes pelo comando“neighbor router-reflector-client”.
O MBGP é configurado dentro do protocolo BGP, porém deve-se separar a família de roteamento com o comando “address-family vpnv4” e dentro da família ativar os vizinhos. Para o envio de prefixos das VPNs, deve-se habilitar o envio de community extendida com o comando “neighbor send-community extended”.
Todos os recursos como route-map, next-hop-self, router-reflector, etc. podem ser configurados dentro da família VPNv4 para manipular ou resolver problemas de roteamento.

1.6.3        Criando uma VPN VRF no BGP

Após todos os roteadores PEs da rede possuem conectividade MBGP, ou diretamente ou por router-reflector, cria-se a VPN com o comando “ip vrf ”, dentro desse comando ficam os parâmentros de marcação da VPN e das communities associadas aos prefixos daquela VPN. Configura-se o Route-Distinguisher da VPN, que deve ser único na rede, com comando “rd :”, e também se cria a community que será exportada para aqueles prefixos de rede com o comando “route-target <export|import>:”, onde “import” significa importar as rotas e “export” exportar as rotas marcadas com aquela community.
Cria-se então uma address-family dentro do BGP com o comando “address-family ipv4 vrf ” com o mesmo nome da VPN criada no “ip vrf” fora do roteamento BGP. Dentro dessa address-family são configuradas as redes que serão redistribuídas para os outros sites. Para divulgar as redes é necessário que a rede exista na tabela de roteamento interna e, ou adicionar o comando “network mask ou redistribuindo rotas para o MBGP com o comando “redistribute ”, que pode ser vinculado a um route-map para definir exatamente as rotas que serão divulgadas de um protocolo para outros sites.
Enfim, para que uma interface conectada ao CE faça parte da VPN BGP, usa-se o comando “ip vrf forwarding ” dentro da interface.

1.6.4        Criando o túnel L2TP L3 para tráfego de VPN

Para criar um túnel multiponto GRE para envio de tráfego das VRFs criadas nos PEs, cria-se uma vrf exclusiva para o transporte dos dados, geralmente chamada de “RiV” que quer dizer Resolve-in-VRF “ip vrf RiV”, dentro da VRF configura-se um RD.
Em seguida, cria-se uma interface túnel “interface tunnel ” na vrf de transporte (no caso, RiV) com um endereço IP na mesma rede do endereço IP das interfaces túnel de todos os outros PEs. Usa-se o o endereço IP da loopback como source do túnel (esse endereço tem que ser acessível pelos outros PEs) “tunnel source loopback 0”. Configura-se o tipo do túnel que deverá ser L2TPv3 multiponto para VPN L3 “tunnel mode l3vpn l2tpv3 multipoint”.
Na vizinhança com os outros PEs ou com o Router Reflector aplica-se um route-map de entrada dizendo que tudo o que é aprendido por aquele peer deve ser enviado para a VRF de transporte, a RiV. Esse route-map tem como set o comando “set ip next-hop in-vrf RiV”.
Para que o roteamento do túnel seja feito entre os PEs, deve-se configurar uma conexão MBGP em uma address-family Tunnel entre o PEs envolvidos ou com um router-reflector.
Por último, configura-se uma rota estática default apontada para a interface tunnel dentro da vrf RiV.

1.7       Observações e Bugs

2      Configuração

2.1       CE1

!
interface FastEthernet0/0
 ip address 10.10.10.1 255.255.255.0
!
ip route 0.0.0.0 0.0.0.0 10.10.10.254
!

2.2       PE1

!
ip cef
!
ip vrf RiV
 rd 12:12
!
ip vrf VPN_A
 rd 1:1
 route-target export 1:1
 route-target import 1:1
!
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface Tunnel12
 ip vrf forwarding RiV
 ip address 12.12.12.1 255.255.255.0
 tunnel source Loopback0
 tunnel mode l3vpn l2tpv3 multipoint           ! modo do tunnel tem que ser l3vpn
 tunnel key 12
!
interface FastEthernet0/0
 ip vrf forwarding VPN_A
 ip address 10.10.10.254 255.255.255.0
!
interface FastEthernet1/0
 ip address 100.100.100.1 255.255.255.252
!
router ospf 1
 router-id 1.1.1.1
 network 1.1.1.1 0.0.0.0 area 0
 network 100.100.100.1 0.0.0.0 area 0
!
router bgp 100
 bgp router-id 1.1.1.1
 neighbor 2.2.2.2 remote-as 200
 neighbor 2.2.2.2 ebgp-multihop 255
 neighbor 2.2.2.2 update-source Loopback0
 !
 address-family ipv4 tunnel
 neighbor 2.2.2.2 activate
!
 address-family vpnv4
 neighbor 2.2.2.2 activate
 neighbor 2.2.2.2 send-community extended
 neighbor 2.2.2.2 route-map RiV_RM in
 !
 address-family ipv4 vrf VPN_A
 redistribute connected
!
 address-family ipv4 vrf RiV
!
!
ip route vrf RiV 0.0.0.0 0.0.0.0 Tunnel12
!
!
route-map RiV_RM permit 10              ! o route-map aponta as rotas para dentro da vrf
 set ip next-hop in-vrf RiV
!

2.3       P

!
interface Loopback0
 ip address 9.9.9.9 255.255.255.255
!
interface FastEthernet0/0
 ip address 100.100.100.2 255.255.255.252
!
interface FastEthernet1/0
 ip address 100.100.100.6 255.255.255.252
!
router ospf 1
 router-id 9.9.9.9
 network 100.100.100.2 0.0.0.0 area 0
 network 100.100.100.6 0.0.0.0 area 0
!

2.4       PE2

!
ip cef
!
ip vrf RiV
 rd 12:12
!
ip vrf VPN_A
 rd 1:1
 route-target export 1:1
 route-target import 1:1
!
!
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!
interface Tunnel12
 ip vrf forwarding RiV
 ip address 12.12.12.2 255.255.255.0
 tunnel source Loopback0
 tunnel mode l3vpn l2tpv3 multipoint
 tunnel key 12
!        
interface FastEthernet0/0
 ip vrf forwarding VPN_A
 ip address 20.20.20.254 255.255.255.0
!
interface FastEthernet1/0
 ip address 100.100.100.5 255.255.255.252
!
router ospf 1
 router-id 2.2.2.2
 network 2.2.2.2 0.0.0.0 area 0
 network 100.100.100.5 0.0.0.0 area 0
!
router bgp 200
 bgp router-id 2.2.2.2
 neighbor 1.1.1.1 remote-as 100
 neighbor 1.1.1.1 ebgp-multihop 255
 neighbor 1.1.1.1 update-source Loopback0
 !
address-family ipv4 tunnel
 neighbor 2.2.2.2 activate
 exit-address-family
 !
 address-family vpnv4
 neighbor 1.1.1.1 activate
 neighbor 1.1.1.1 send-community extended
 neighbor 1.1.1.1 route-map RiV_RM in
!
 address-family ipv4 vrf VPN_A
 redistribute connected
!
 address-family ipv4 vrf RiV
!
ip route vrf RiV 0.0.0.0 0.0.0.0 Tunnel12
!        
!
route-map RiV_RM permit 10
 set ip next-hop in-vrf RiV
!

2.5       CE2

!
interface FastEthernet0/0
 ip address 20.20.20.1 255.255.255.0
!
ip route 0.0.0.0 0.0.0.0 20.20.20.254
!
Conteúdo salvo para uso pessoal em laboratórios, devido ao pouco conteúdo deste nível ccie provider em BR.

Autor original: Bruno Barata

Fonte: http://babarata.blogspot.com.br/

EIGRP – Básico

tux_kisuke

1        Teoria EIGRP

O EIGRP é um protocolo de roteamento de convergência rápida de fácil configuração que usa o protocolo DUAL. Tem uso de largura de banda reduzido, pois não envia updates periódicos. O EIGRP é considerado um Advanced distance Vector e usa o máximo de 255 hops e 100 de default.

Possui suporte a VLSM e classless routing com sumarização automática ou manual sendo compatível com IGRP se usar o mesmo AS. Capaz de fazer balanceamento de carga em 4 links por default ou 6 configuráveis.

Suporta todas as redes multiaccess, point-to-point e NBMA (Frame-Relay). A Métrica é composta por Bandwidth e Delay como default, mas pode usar: MTU, Loading e Reliability. É a métrica do IGRP x 256. Redes com muitos caminhos alternativos geralmente gera problemas na convergência EIGRP.

Comunicação multicast no 224.0.0.10, Hello de 5s para links maiores que 1.544MB e 60s para menor. Dead time de 3 vezes o hello. Utiliza o RTP (cisco) como protocolo de transporte confiável para envio de update;

1.1           Terminologia

  • Neightbor table: Cada router tem uma tabela com seus routers adjacentes;
  • Neighbor Address: Endereço de rede do vizinho (IP);
  • Q (Queue): Fila de pacotes esperando para serem enviados (0 é normal);
  • SRTT (Smooth Round Trip Timer): O tempo mais rápido que enviou e recebeu um pacote;
  • Hold Time: Tempo máximo até colocar o vizinho em OFF, geralmente 3x o tempo do Hello;
  • Topology table: Cada router tem uma tabela de topologia que inclui todos os caminhos aprendidos para cada protocolo;
  • Routing table: EIGRP escolhe o melhor router (successor) para um caminho e coloca na tabela de rotas;
  • Successor: O successor é o router escolhido como primeira opção para um caminho;
  • Feasible successor: Router de backup é escolhido junto com o successor (principal);
  • FD (feasible distance): Distância Possível, é a soma dos custos de todos os links até o destino;
  • AD (advertised distance): Distancia anunciada, é a soma dos custos do vizinho até o destino.

1.2           Tipos de Mensagens

  • Hello: Usados para descobrir vizinhos por multicast no 224.0.0.10 não confiável de 5 em 5s  para links maiores que 1.544MB ou de 60 em 60s para menores. Envia também o dead time (3x o tempo de hello);
  • Update: Pacotes update requer confirmação (confiável RTP) e são enviados para comunicar que um router especifico sofreu convergência. São enviados por multicast quando um novo router é descoberto;
  • Query: Pacotes que requerem confirmação (confiável RTP) e perguntam se existe um router de backup para um determinado caminho
  • Reply: Pacotes de resposta a um Query que requerem confirmação (confiável RTP), enviado por Unicast somente a quem perguntou;
  • Acknowledgment (ACK): Pacotes de confirmação enviado por unicast. Pacotes como: Update, query e reply precisam de confirmação.
  • Obs: Pacotes de confiança só são retransmitidos 16 vezes, caso contrário o vizinho é considerado Dead.

1.3           Relacionamento com Vizinhos

EIGRP envia multicasts periódicos (hello) pela interface (com IP primário, pois o secundário não forma adjacências) para descobrir vizinhos, quando outro router pertence ao mesmo AS ele recebe o hello e estabelece uma relação de vizinhos mantendo assim as informações de seus vizinhos na sua Neighbor Table.

Quando o vizinho para de responder os pacotes hello e o hold time acaba (3 vezes o tempo do hello), ele considera o vizinho não operacional, assim toda a tabela de topologia aprendida pelo vizinho é deletada e é feita uma convergência.

Os pacotes Hello são enviados de 60 em 60 segundos nos circuitos de largura de banda menor ou igual a T1 como: ISDN BRI, SMDS, etc.

O EIGRP não informa ao vizinho se as suas métricas estiverem mal combinadas, não informa a vizinhos de diferente AS e o pacote Hello é enviado com o endereço primário da interface.

Query (perguntas) são enviadas quando um router é perdido e não existe um sucessor confiável (feasible sucessor) para procurar um caminho alternativo. O router entra em modo ativo e envia queries para todos os routers vizinhos que por sua vez enviam queries para outros vizinhos menos o que lhe enviou inicialmente. Uma solução para reduzir essa propagação é a sumarização de rotas, pois raramente um router remoto precisa saber todas as rotas que são divulgadas em toda rede.

Dual envia a informação de atualização apenas aos routers que precisam, diferente do link-state que envia para todos os vizinhos.

1.4           Descobrindo um Vizinho e Definindo Melhores Rotas

  1. Um novo router A entra na rede e envia um pacote Hello pelas interfaces;
  2. Router B da rede recebe esse hello e responde com pacote update com todos as rotas que ele tem em sua tabela de rotas menos as rotas aprendidas pelo novo router A (split horizon);
  3. Router A responde com um ACK confirmando o recebimento das informações;
  4. Router A ajusta todos os pacotes de update na sua tabela de topologia associando a métrica para alcançar cada destino;
  5. Router A troca pacotes update com cada vizinho;
  6. Cada router envia um ACK de confirmação para o Router A;
  7. Quando todos os routers têm todas as rotas eles estão prontos para escolher as rotas primarias e rotas de backup para manter na Topology Table;
  8. Pelo Dual ele define melhor rota baseado no bandwidth, Delay, Reliability, Loading e MTU;
  9. Se uma rota é perdida o router entra em “Active” procurando por um feasible Sucessor, passado 3min ele volta ao normal;
  10. Se um router está muito ocupado (alto uso de memória) para responder a query e enviar reply de outros routers ou o link estiver funcionando apenas em um sentido ele se encontra em SIA – Stuck in Active.

1.5           DUAL

  • FD (Feasible distance) – Distância confiável é a soma dos custos dos enlaces para alcançar a rede de destino;
  • AD (Advertised Distance) – Distância anunciada é a soma dos custos dos enlaces para a rede de destino anunciado pelos vizinhos;
  • Sucessor – Caminho escolhido para a rede de destino;
  • FS (Feasible Sucessor) – Sucessor confiável para um caminho alternativo para a rede.

1.6           Configuração de EIGRP

  • Ative o EIGRP definindo o AS que deve coincidir com todos da rede;
  • Divulgar as redes que fazem parte do EIGRP. As redes determinam as interfaces que farão parte do EIGRP;
  • O bandwidth default da interface serial é T1 (1.544MB), para mudar use o comando bandwidth na interface;
  • Quando se configura interfaces point-to-multipoint, principalmente em Frame Relay, é importante entender que todos os vizinhos compartilham uma banda igualmente em que a soma dos links de cada vizinho é o bandwidth da serial do router, por isso é importante que a velocidade da serial seja a menor velocidade de todos os links multiplicada pelo número de sub-interfaces;
  • Na topologia point-to-point com 10 links, todos os circuitos virtuais (subinterfaces) usam o bandwidth de 1/10 da interface, isto é, se o link da interface s0 for 256, cada VC (subinterface, s0.1… s0.10) terá um BW de 25;
  • Quando uma rota é aprendida pela sub-interface de uma interface, essa mesma rota não é replicada para outra sub-interface dessa mesma interface devido ao split-horizon.

1.7           Balanceamento de Carga

  • Carga balanceada em 4 links de custos iguais por default, máximo de 6 links;
  • O balanceamento de links de custos diferentes é de acordo com a métrica da rota, e é default;
  • Quando o balanceamento é feito por links de custos diferentes os pacotes são enviados por turnos, o numero de pacotes é inversamente proporcional a métrica da rota;
  • O comando “variance” é usado para adicionar outros links de custos diferentes criando uma margem a ser considerada como load-balance;

2        Cenário

2.1           Objetivo

Seis roteadores (C1, C2, C3, R1, R3 e R6) são conectados conforme a topologia abaixo e devem ser configurados seguindo os seguintes critérios.

Todos os roteadores deverão pertencer a uma rede EIGRP com AS = 1.

Os roteadores R1 e R6 deverão redistribuir as rotas estáticas configuradas.

Os roteadores C1 deverá sumarizar as rotas vindas dos roteadores R1, porém o R6 deverá divulgar as rotas sem sumariza-las.

O roteador R3 deverá gerar uma rota default para a rede EIGRP.

Todos os roteadores deverão usar suas interfaces loopbacks como Router-ID.

2.2           Topologia

eigrp-basico

Figure-01:              Topologia

2.3           IOS utilizados

  • C1, C2, C3, R1, R3 e R6 – c7200-js-mz.123-7.T.bin

2.4           Configuração dos Roteadores

Em todos os roteadores configura-se o roteamento EIGRP pelo comando “router eigrp ” onde o “AS” é o Autonomous System que deverá ser igual em todos os roteadores do mesmo domínio. O roteador também possui um router ID único que é configurado pelo comando “eigrp router-id ” dentro das configurações de roteamento.

Uma interface fica habilitada a fazer vizinhança quando a rede pertencente aquela interface está no comando “network ” está configurado no routeamento EIGRP. Caso seja necessário divulgar a rede da interface mas não habilita-la para fazer vizinhança EIGRP, usa-se o “passive-interface ” dentro das configurações de roteamento EIGRP.

Por padrão o EIGRP sumariza automaticamente as rotas para o seu vizinho. Pode-se cancelar essa sumarização automática com o comando “no auto-summary”. Desabilitar essa auto sumarização é comum para evitar loops em redes não planejadas, porém a tabela fica maior.

No EIGRP a rota default é gerada para um vizinho configurando um endereço sumarizado 0/0 na interface com o vizinho com o comando “ip summary-address eigrp 0.0.0.0 0.0.0.0”.

2.5           Observações e Bugs

Documentação:

http://www.cisco.com/en/US/partner/docs/ios/12_2/ip/configuration/guide/1cfeigrp.html#wp1001004

2.6           Comandos Importantes de Verificação

C2#sh ip route

Gateway of last resort is 30.30.30.2 to network 0.0.0.0

D    1.0.0.0/8 [90/2681856] via 12.12.12.1, 00:19:17, Serial1/6

6.0.0.0/8 is variably subnetted, 5 subnets, 2 masks

D       6.6.6.6/32 [90/2809856] via 23.23.23.1, 00:05:27, Serial1/7

D EX    6.2.0.0/24 [170/2681856] via 23.23.23.1, 00:05:27, Serial1/7

D EX    6.3.0.0/24 [170/2681856] via 23.23.23.1, 00:05:27, Serial1/7

D EX    6.0.0.0/24 [170/2681856] via 23.23.23.1, 00:05:27, Serial1/7

D EX    6.1.0.0/24 [170/2681856] via 23.23.23.1, 00:05:27, Serial1/7

23.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

C       23.23.23.0/30 is directly connected, Serial1/7

D       23.0.0.0/8 is a summary, 00:19:16, Null0

10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

D       10.0.0.0/8 is a summary, 00:19:16, Null0

C       10.10.10.102/32 is directly connected, Loopback0

12.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

C       12.12.12.0/30 is directly connected, Serial1/6

D       12.0.0.0/8 is a summary, 00:19:17, Null0

D    13.0.0.0/8 [90/2681856] via 12.12.12.1, 00:07:17, Serial1/6

D    60.0.0.0/8 [90/2681856] via 23.23.23.1, 00:19:17, Serial1/7

30.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

C       30.30.30.0/30 is directly connected, Serial1/0

D       30.0.0.0/8 is a summary, 00:23:04, Null0

D*   0.0.0.0/0 [90/2297856] via 30.30.30.2, 00:06:51, Serial1/0

C2#show ip eigrp neighbors

IP-EIGRP neighbors for process 1

H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq

(sec)         (ms)       Cnt Num

2   30.30.30.2              Se1/0             12 00:08:07  184  1104  0  40

1   23.23.23.1              Se1/7             11 00:21:21   83   498  0  32

0   12.12.12.1              Se1/6             13 00:23:42  106   636  0  62

C1#show ip eigrp topology

IP-EIGRP Topology Table for AS(1)/ID(10.10.10.101)

Codes: P – Passive, A – Active, U – Update, Q – Query, R – Reply,

r – reply Status, s – sia Status

P 6.6.6.6/32, 1 successors, FD is 3321856

via 12.12.12.2 (3321856/2809856), Serial1/7

P 0.0.0.0/0, 1 successors, FD is 2297856

via 13.13.13.2 (2297856/128256), Serial1/5

P 1.0.0.0/8, 1 successors, FD is 2169856

via 10.10.10.2 (2169856/256), Serial1/0

P 6.2.0.0/24, 1 successors, FD is 3193856

via 12.12.12.2 (3193856/2681856), Serial1/7

P 6.3.0.0/24, 1 successors, FD is 3193856

via 12.12.12.2 (3193856/2681856), Serial1/7

P 6.0.0.0/24, 1 successors, FD is 3193856

via 12.12.12.2 (3193856/2681856), Serial1/7

P 6.1.0.0/24, 1 successors, FD is 3193856

via 12.12.12.2 (3193856/2681856), Serial1/7

P 10.0.0.0/8, 1 successors, FD is 128256

via Summary (128256/0), Null0

P 10.10.10.0/30, 1 successors, FD is 2169856

via Connected, Serial1/0

P 12.0.0.0/8, 1 successors, FD is 2169856

via Summary (2169856/0), Null0

P 12.12.12.0/30, 1 successors, FD is 2169856

via Connected, Serial1/7

P 13.0.0.0/8, 1 successors, FD is 2169856

via Summary (2169856/0), Null0

P 13.13.13.0/30, 1 successors, FD is 2169856

via Connected, Serial1/5

P 23.0.0.0/8, 1 successors, FD is 2681856

via 12.12.12.2 (2681856/2169856), Serial1/7

P 30.0.0.0/8, 1 successors, FD is 2681856

via 12.12.12.2 (2681856/2169856), Serial1/7

P 60.0.0.0/8, 1 successors, FD is 3193856

via 12.12.12.2 (3193856/2681856), Serial1/7

P 10.10.10.101/32, 1 successors, FD is 128256

via Connected, Loopback0

Configuração

2.7           R1

!router eigrp 1

redistribute static

network 1.1.1.1 0.0.0.0

network 10.10.10.0 0.0.0.3

auto-summary

eigrp router-id 1.1.1.1

!

 

2.8           C1

!router eigrp 1

network 10.10.10.0 0.0.0.3

network 10.10.10.101 0.0.0.0

network 12.12.12.0 0.0.0.3

network 13.13.13.0 0.0.0.3

auto-summary

eigrp router-id 10.10.10.101

!

2.9           C2

!router eigrp 1

network 10.10.10.102 0.0.0.0

network 12.12.12.0 0.0.0.3

network 23.23.23.0 0.0.0.3

network 30.30.30.0 0.0.0.3

auto-summary

eigrp router-id 10.10.10.102

!

2.10     R3

!interface Serial1/0

ip address 30.30.30.2 255.255.255.252

ip summary-address eigrp 1 0.0.0.0 0.0.0.0 5

!

interface Serial1/4

ip address 33.33.33.2 255.255.255.252

ip summary-address eigrp 1 0.0.0.0 0.0.0.0 5

!

interface Serial1/5

ip address 13.13.13.2 255.255.255.252

ip summary-address eigrp 1 0.0.0.0 0.0.0.0 5

!

router eigrp 1

network 3.3.3.3 0.0.0.0

network 13.13.13.0 0.0.0.3

network 30.30.30.0 0.0.0.3

network 33.33.33.0 0.0.0.3

auto-summary

eigrp router-id 3.3.3.3

!

2.11     C3

!router eigrp 1

network 10.10.10.103 0.0.0.0

network 23.23.23.0 0.0.0.3

network 60.60.60.0 0.0.0.3

auto-summary

eigrp router-id 10.10.10.103

!

2.12     R6

!router eigrp 1

redistribute static

network 6.6.6.6 0.0.0.0

network 60.60.60.0 0.0.0.3

no auto-summary

eigrp router-id 6.6.6.6

!

Autor original: Bruno Barata

Fonte: http://babarata.blogspot.com.br/

Recomendação de conteúdo LPI

tux_luffy

Fala pessoal, ando corrido por isso hoje segue uma dica para seus estudos e melhor ainda de graça.

Site com muito conteúdo de qualidade deem muitos likes.

 

https://www.youtube….sontreinamentos

 

www.bosontreinamentos.com.br

 

Abs!