Monthly Archives: maio 2016

AToM – Ethernet sobre MPLS com VLAN

tux_cisco
Olá pessoal segue outro guia bastante utilizado para entrega de circuitos em ambientes ISP com Cisco/JUN lab de nível médio.
O Any Transport over MPLS (AToM) é uma solução usada para transportar pacotes L2 através de um backbone MPLS. O AToM permite a conectividade entre os sites dos clientes com suas tecnologias L2 existentes através da infraestrutura de rede baseada em pacote.
Com a tecnologia AToM o aprovisionamento e a conectividade são diretas. Um cliente usando Ethernet num edifício ou campus em um local pode se conectar por meio de um provedor via Ethernet sobre MPLS a clientes em locais remotos.
AToM estabelece um quadro comum para encapsular e transportar trafegos Layer 2 sobre a rede MPLS. Os provedores podem usar uma infra-estrutura única MPLS para oferecer aos clientes a conectividade Layer 2.
O AToM suporta os tipos de transporte abaixo:
•      ATM AAL5 over MPLS
•      ATM Cell Relay over MPLS
•      Ethernet VLAN over MPLS
•      Frame Relay over MPLS
•      PPP over MPLS
•      HDLC over MPLS

Ethernet over MPLS

O transporte do L2 funciona através do encapsulamento Ethernet PDUs em pacotes MPLS e encaminha-os através da rede MPLS. Cada PDU é transportado como um único pacote. As seguintes etapas descrevem o processo de encapsular o PDU.

Ingress PE Router

•      O PE de entrada recebe o PDU e remove o preamble, o delimitador do frame (SFD), e o frame check sequence (FCS). O resto do cabeçalho permanece o mesmo.
•      O PE copia o codigo de controle do cabeçalho, mesmo que não seja usado, adiciona um label VC e um label do túnel LSP para o roteamento normal do MPLS através do backbone. A rede roteia os dados usando o tunnel LSP convencional do MPLS sem distinguir o tipo de tráfego.

Egress PE Router

•      O PE de destino recebe o pacote e remote o label do LSP, caso exista (Penultimo geralmente retira), retira o label de controle e o label do VOCÊ;
•      O PE atualiza o cabeçalho se necessário e envia o pacote para o CE associado.


Objetivo

Cinco roteadores (CE1, PE1, P, PE2 e CE2) são conectados formando um backbone com 3 roteadores e dois CEs conectados. Pede-se:
•      O protocolo de roteamento de backbone PE1-P-PE2 deverá ser o OSPF na área 0 com todas as interfaces divulgadas e com LDP entre os PEs para tráfego MPLS;
•      O CE1 e o CE2 e deverão se comunicar via o backbone usando túnel AToM.

Topologia

IOS utilizados

• CE1, PE1, P, PE2 e CE2 – c7200-k91p-mz.122-25.S15.bin

Configuração dos Roteadores

Configurações do OSPF do Backbone

Em todos os roteadores configura-se o roteamento OSPF pelo comando “router ospf ” onde o “processo” é um numero do processo OSPF. O roteador também possui um router ID único que geralmente é a interface loopback ou então o maior endereço IP do roteador.
Para adicionar interfaces deve-se usar o comando “network

área

”. Um roteador pode ter interfaces em áreas distintas, define-se cada área pelo comando network e o tipo da área com o comando “area [type]”.

Configurações do MPLS

Antes de qualquer configuração, o Cisco Express forwarding deve ser habilitado com o comando “ip cef”. Para habilitar o MPLS no modo LDP, usa-se o comando global “mpls label protocol ldp”.
Para habilitar o MPLS nas interfaces, configura-se “mpls ip”.

Configuração do Túnel AToM

O tunnel L2 AToM é configurado na interface do PE conectada diretamente ao CE com o comando “xconnect encapsulation mpls”. O ID do VOCÊ tem que ser o mesmo nos dois PEs.
Para interface em trunk, deve-se configurar o trunk na interface do PE.

Observações e Bugs

 

Configuração

 

CE1

 

!
interface FastEthernet1/0.10
 encapsulation dot1Q 10
 ip address 10.10.10.1 255.255.255.0
!

 

 PE1

 

!
ip cef
!
mpls label protocol ldp
!
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet1/0.10
 encapsulation dot1Q 10
 xconnect 2.2.2.2 100 encapsulation mpls
!
interface FastEthernet2/0
 ip address 13.13.13.1 255.255.255.0
 mpls ip
!
router ospf 1
 router-id 1.1.1.1
 network 1.1.1.1 0.0.0.0 area 0
 network 13.13.13.1 0.0.0.0 area 0
!

 

 

P

 

!
ip cef
!
mpls label protocol ldp
!
!
interface Loopback0
 ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet1/0
 ip address 13.13.13.3 255.255.255.0
 mpls ip
!
interface FastEthernet2/0
 ip address 23.23.23.3 255.255.255.0
 mpls ip
!
router ospf 1
 router-id 3.3.3.3
 network 3.3.3.3 0.0.0.0 area 0
 network 13.13.13.3 0.0.0.0 area 0
 network 23.23.23.3 0.0.0.0 area 0
!

 

 PE2

 

!
ip cef
!
mpls label protocol ldp
!
!
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet1/0.10
 encapsulation dot1Q 10
 xconnect 1.1.1.1 100 encapsulation mpls
!
interface FastEthernet2/0
 ip address 23.23.23.2 255.255.255.0
 mpls ip
!
router ospf 1
 router-id 2.2.2.2
 network 2.2.2.2 0.0.0.0 area 0
 network 23.23.23.2 0.0.0.0 area 0
!

 

CE2

 

!
interface FastEthernet1/0.10
 encapsulation dot1Q 10
 ip address 20.20.20.1 255.255.255.0
!
Fonte: http://babarata.blogspot.com.br/2013/04/v-behaviorurldefaultvmlo_30.html

Configuração da Nuvem MPLS em Provedores

tux_cisco

Olá pessoal hoje trago um post um pouco mais avançado que trata várias técnologias, tais como EIGRP /BGP / VRF / e o personagem principal “MPLS”

 

Softfware utilizado para simulação : GNS3 https://www.gns3.com/ faça seu cadastro faça a instalação, adicione o IOS 36xx no post abaixo, pra quem não conhece o GNS3 ou não usou veja um video no youtube para aprender usar IDLEPC responsável por deixar o processamento dos roteadores mais baixo.

Post de EIGRP caso queira mais teoria -> http://flexpabx.com.br/blog/?p=569

 

Utilizei como base de conhecimento o livro do professor Samuel Henrque Brito, lab de configração de nuvem MPLS

Abaixo o post completo.

Observações,  passos que tomaremos neste post

  1. Configuração Básica das Interfaces e Endereços IP ( Dica Flex, faça o desenho como no post desde o inicio anote os ips no excell ou bloco ne notas para evitar conflitos mentais, ligue interfaces similares sempre exemplo fast 0/0 com 0/0
  2. Roteamento IGP (EIGRP) na Nuvem da Operadora (AS 200)
  3. Criação e Associação da VRF e Configuração do RD/RT (Dica Flex, leia várias vezes o conceito dessa parte para fixar essa informação super importante.)
  4. Configuração do Roteamento EIGRP no PE e CE
  5. Configuração da Redistribuição de Rotas EIGRP e BGP ( Dica FLEX ATENÇÃO, isso aqui pode dar um crash nos leitores mas tentando ser didático e usar linguagem popular, nessa parte de nosa configuração é necessário redistribuir as rotas eigrp dentro do BGP e vice versa, acesse o BGP 200 e joguei dentro da VRF cliente 1 e 2 o eigrp e depois acesse o EIGRP 1 e jogue o BGP 200.
  6. Configuração do MP-BGP no(s) PE

Usei interfaces fast em todos routers, não vejo mais uso de serial hoje em dia, IOS utilizado Cisco IOS v12.4 Plataforma 3600

 

TOPOLOGIA-MPLS

 

Post original : https://labcisco.blogspot.com.br/2013/01/configuracao-da-nuvem-mpls-em-provedores

Esse post traz um assunto relevante no contexto atual das telecomunicações que é o MPLS.Atualmente a tecnologia MPLS (Multi-Protocol Label Switching) é comumente utilizada pelas operadoras de telecomunicações (ISP) como solução de conectividade de longa distância.
E antes de entrar na discussão técnica, uma primeira observação importante é que a configuração dessa tecnologia no ambiente corporativo (enterprise) é totalmente diferente da configuração na nuvem da operadora (ISP).
Aliás, quem possui um link MPLS na empresa sabe bem que ela é transparente, já que você simplesmente recebe a conectividade da operadora e pronto – é como se houvesse um link privado entra as unidades remotamente conectadas… Bom, então se a coisa é simples assim qual seria a razão da “novela” que se faz acerca dessa tecnologia?
A simplicidade de uns é a complexidade de outros! Os roteadores instalados na empresa cliente normalmente sequer têm noção do que é MPLS e por isso toda a complexidade da infraestrutura está na nuvem da operadora.
Diferente de outras tecnologias de Camada 2 (HDLC, ATM e Frame-Relay) que eram tradicionalmente utilizadas na longa distância (e ainda são), o MPLS surgiu como uma tecnologia de Camada 2¹/² que traz uma abordagem de operação totalmente nova: o chamado roteamento baseado em rótulos.
Essa tecnologia não utiliza mais o cabeçalho do datagrama IP na decisão de roteamento, fazendo o reencapsulamento do datagrama com um novo cabeçalho de 4 bytes que possui um rótulo de 20 bits. Toda a decisão de encaminhamento dos pacotes é determinada com base nesse rótulo, o que agiliza o processo de roteamento e permite a implementação de técnicas de engenharia de tráfego, entre outras coisas mais.
O assunto é extenso e obviamente que o meu objetivo não é substituir um bom livro sobre o assunto – por isso serei o mais objetivo possível e o foco é que vocês consigam reproduzir um cenário prático de MPLS. Vamos trabalhar com o  cenário observado na figura abaixo.
Antes de partir para a configuração, existem vários conceitos fundamentais que o leitor precisa ter em mente para entender o papel dos elementos envolvidos no cenário. Então que tal começar pelocomeço? Parece razoável… 😉
O Custormer Edge (CE) é o equipamento instalado nas unidades remotas da empresa que irão receber a solução de conectividade provida pela operadora. Outro elemento importante é oProvider Edge (PE) que se trata do roteador da operadora diretamente conectado a um (ou mais) roteador(es) do(s) cliente(s), ou seja, PEs são conectados a CEs. Por fim, o elemento P (Provider)são os demais roteadores distribuídos pela nuvem MPLS que representa a infraestrutura de rede da operadora.

Outro conceito fundamental é a tecnologia VRF (Virtual Routing and Forwarding) que traz consigo outros dois elementos igualmente importantes: o RD (Route Distinguisher) e o RT (Route Target). Através do VRF é possível criar múltiplas instâncias da tabela de roteamento, sendo que cada uma dessas tabelas virtuais é totalmente independente das demais. No contexto do MPLS é comum que cada cliente tenha sua própria VRF porque essa prática traz mais segurança e flexibilidade.

Sem as VRFs individuais o tráfego entre as sub-redes de todos os clientes da operadora iriam compor uma única tabela de roteamento, o que seria péssimo do ponto de vista de segurança. Outro benefício comum é que se torna possível que os clientes utilizem endereços de redes iguais, já que as instâncias VRF são independentes. E é muito comum que as empresas utilizem endereços privados da RFC1918 (192.168 /16, 172.16 /12 e 10 /8).

No entanto, em algum momento é necessário que as rotas entre o roteador da empresa (CE) e o roteador da operadora (PE) sejam redistribuídas para um processo BGP no PE. Isso porque deve existir um pareamento iBGP entre um PE e outro PE remoto para viabilizar na prática a chamada VPN MPLS, um túnel abstrato que só existe nas bordas da rede MPLS, já que os roteadores P sequer conhecem as várias VPNs.

Eis que surge um problema: Fica claro que é possível ter endereços repetidos através das VRFs porque elas representam tabelas de roteamento distintas, mas como fica a redistribuição das rotas iguais para o processo BGP!!!??? Isso só é possível através da adição de um identificador nas rotas para torná-las únicas que é denominado RD (Route Distinguisher). Também existe o RT (Route Target), uma community BGP que indica o membro de uma VPN, permitindo que rotas sejam importadas e exportadas das VRFs no processo de redistribuição.

Há alguns formatos para o RD/RT, sendo que sua forma mais comum consiste em:
ASN de 16 Bits + Número de 32 Bits ; Ex.: 65000:100.

No cenário apresentado nesse post teremos duas VRFs denominadas Cliente1 e Cliente2 que serão identificadas da seguinte forma:

– VRF Cliente 1, RD 65001:111, RT 65001:1
– VRF Cliente 2, RD 65002:222, RT 65002:2

Mesmo com “toda” essa carga teórica, acreditem que fui bastante sucinto e fiz o possível para “suavizar” essa postagem apresentando apenas os conceitos fundamentais. Como o processo de configuração consiste em várias linhas de comando, estarei dividindo o processo de configuração nas seguintes etapas:

  1. Configuração Básica das Interfaces e Endereços IP
  2. Roteamento IGP (EIGRP) na Nuvem da Operadora (AS 200)
  3. Criação e Associação da VRF e Configuração do RD/RT
  4. Configuração do Roteamento EIGRP no PE e CE
  5. Configuração da Redistribuição de Rotas EIGRP e BGP
  6. Configuração do MP-BGP no(s) PE

As etapas 1 e 2 não dizem respeito à configuração do MPLS propriamente dito, no entanto são pré-requisitos para o cenário funcionar devidamente. Como os roteadores da empresa (CE) nao têm ciência do MPLS, eles possuem apenas configurações básicas.

1) Configuração Básica das Interfaces e Endereços IPA única configuração que merece destaque nessa primeira etapa é que estamos habilitando o encapsulamento MPLS na interface que se conecta a outro roteador da nuvem da operadora.Reparem que as interfaces que se conectam aos roteadores CE não têm essa configuração, já queo tráfego até o PE é puramente IP.

2) Roteamento IGP (EIGRP) na Nuvem da Operadora (AS 200)

Essa segunda etapa também é bem básica, consistindo apenas na configuração de um protocolo de roteamento IGP qualquer na nuvem da operadora. Não há nenhum destaque especial, então apenas trarei os comandos:

3) Criação e Associação da VRF e Configuração do RD/RT

A configuração abaixo é necessária apenas nos roteadores de borda (PE), já que os roteadores da empresa (CE) não têm ciência do MPLS. Reparem que em cada roteador de borda criamos duas VRFs e informamos os valores RD/RT previamente definidos. Por fim, associamos cada VRF com sua respectiva interface (cliente).

4) Configuração do Roteamento EIGRP no PE e CE

A próxima etapa consiste na configuração de um protocolo de roteamento entre a empresa para que o provedor possa conhecer as rotas anunciadas pela empresa. Esse processo de configuração é bem simples nos roteadores da empresa (CE), no entanto há alguns comandos adicionais nos roteadores do provedor (PE) que são necessários para associar as rotas de cada cliente com sua respectiva VRF anteriormente criada.

Talvez a observação mais importante aqui é que o número de AS utilizado nos processos EIGRP do CE e PE não precisam ser iguais, uma vez que na configuração EIGRP do PE há uma sub-seção de configuração para cada VRF em que devemos informar o mesmo número utilizado no processo do roteador remoto (CE). Caso contrário, as rotas dos diversos clientes seriam todas compartilhadas na tabela de roteamento padrão, o que não é desejado…

***

(*)

(*) Obs.: No processo EIGRP dos roteadores PE que irão estabelecer vizinhança com os roteadores CE utilizamos o AS 1 para não misturar as rotas dos clientes com o processo EIGRP 200 que utilizamos nas primeiras etapas para trocar as rotas internas entre os roteadores da nuvem MPLS.  

5) Configuração da Redistribuição de Rotas EIGRP e BGP

Até agora os roteadores PE já aprenderam as rotas dos clientes diretamente conectados, no entanto não existe uma ligação entre as unidades remotas dos clientes porque o PE1 não está diretamente ligado ao PE2. Ou seja, PE1 conhece as rotas anunciadas por CE1A, mas não é capaz de receber as rotas de CE1B.

Na próxima etapa a gente vai configurar um pareamento iBGP entre PE1 e PE2 para criar a abstração do túnel da VPN/MPLS. No entanto, antes temos que configurar a redistribuição mútua entre o EIGRP estabelecido com os roteadores CE e o BGP que estará em execução nos roteadores PE.

6) Configuração do MP-BGP no(s) PE

O último passo consiste no estabelecimento do túnel virtual entre as unidades remotas da empresa para prover ao cliente a abstração de que existe uma conexão privada de longa distância (WAN) entre as unidades. Assim que essa configuração for feita, os roteadores CE1A e CE1B vão conhecer as rotas uns dos outros e a empresa terá conectividade remota!

Pronto! Depois de MUITAS linhas de comando já temos uma implementação básica de VPN/MPLS funcionando entre duas empresas clientes, cada uma com apenas duas unidades remotas. Aovisualizar a tabela de roteamento VRF Cliente1 no roteador PE1 é possível observar que a rota 192.168.2.0/24 da unidade remota foi aprendida via BGP.

PE1#show ip route vrf Cliente1

Routing Table: Cliente1
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route

Gateway of last resort is not set

172.16.0.0/30 is subnetted, 2 subnets
C       172.16.1.0 is directly connected, Serial2/0
B       172.16.3.0 [200/0] via 2.2.2.2, 00:02:37
D    192.168.1.0/24 [90/2172416] via 172.16.1.2, 00:42:44, Serial2/0
B    192.168.2.0/24 [200/2172416] via 2.2.2.2, 00:02:37

Também vamos aproveitar que tivemos todo esse trabalho para observar a tabela BGP do PE1, já que assim fica evidente a importância do identificador RD.

PE1#show ip bgp vpnv4 all
BGP table version is 17, local router ID is 1.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i – internal,
r RIB-failure, S Stale
Origin codes: i – IGP, e – EGP, ? – incomplete

Network          Next Hop            Metric LocPrf Weight Path
Route Distinguisher: 65001:111 (default for vrf Cliente1)
*> 172.16.1.0/30    0.0.0.0                  0         32768 ?
*>i172.16.3.0/30    2.2.2.2                  0    100      0 ?
*> 192.168.1.0      172.16.1.2         2172416         32768 ?
*>i192.168.2.0      2.2.2.2            2172416    100      0 ?
Route Distinguisher: 65002:222 (default for vrf Cliente2)
*> 172.16.2.0/30    0.0.0.0                  0         32768 ?
*>i172.16.4.0/30    2.2.2.2                  0    100      0 ?
*> 192.168.1.0      172.16.2.2         2172416         32768 ?
*>i192.168.2.0      2.2.2.2            2172416    100      0 ?

Agora vamos observar a tabela de roteamento do roteador CE1A instalado na empresa. Observem que ele apenas conhece a rota remota como se as unidades estivessem diretamente conectadas entre si. Essa é a grande vantagem da implementação VPN do MPLS, afinal o cliente não enxerga a nuvem MPLS.

CE1A#show ip route
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route

Gateway of last resort is not set

172.16.0.0/30 is subnetted, 2 subnets
C       172.16.1.0 is directly connected, Serial2/0
D       172.16.3.0 [90/2681856] via 172.16.1.1, 00:08:33, Serial2/0
C    192.168.1.0/24 is directly connected, FastEthernet0/0
D    192.168.2.0/24 [90/2684416] via 172.16.1.1, 00:08:34, Serial2/0

Para finalizar esse post (que já está extenso demais), há vários comandos de exibição (show) que podemos utilizar para verificar o efeito de todas as configurações realizadas em cada uma das etapas.  Por isso deixo registrada uma relação de comandos de exibição caso o leitor queira reproduzir o cenário e sugiro uma observação detalhada das tabelas VRF e BGP.

PE1# show ip route
PE1# show ip route vrf Cliente1
PE1# show ip route vrf Cliente2
PE1# show ip bgp 
PE1# show ip bgp summary
PE1# show ip bgp vpnv4 all  
PE1# show ip eigrp vrf Cliente1 neighbors
PE1# show ip eigrp vrf Cliente2 neighbors
PE1# show ip eigrp vrf Cliente1 topology
PE1# show ip eigrp vrf Cliente2 topology