Tag Archives: vlan

AToM – Ethernet sobre MPLS com VLAN

tux_cisco
Olá pessoal segue outro guia bastante utilizado para entrega de circuitos em ambientes ISP com Cisco/JUN lab de nível médio.
O Any Transport over MPLS (AToM) é uma solução usada para transportar pacotes L2 através de um backbone MPLS. O AToM permite a conectividade entre os sites dos clientes com suas tecnologias L2 existentes através da infraestrutura de rede baseada em pacote.
Com a tecnologia AToM o aprovisionamento e a conectividade são diretas. Um cliente usando Ethernet num edifício ou campus em um local pode se conectar por meio de um provedor via Ethernet sobre MPLS a clientes em locais remotos.
AToM estabelece um quadro comum para encapsular e transportar trafegos Layer 2 sobre a rede MPLS. Os provedores podem usar uma infra-estrutura única MPLS para oferecer aos clientes a conectividade Layer 2.
O AToM suporta os tipos de transporte abaixo:
•      ATM AAL5 over MPLS
•      ATM Cell Relay over MPLS
•      Ethernet VLAN over MPLS
•      Frame Relay over MPLS
•      PPP over MPLS
•      HDLC over MPLS

Ethernet over MPLS

O transporte do L2 funciona através do encapsulamento Ethernet PDUs em pacotes MPLS e encaminha-os através da rede MPLS. Cada PDU é transportado como um único pacote. As seguintes etapas descrevem o processo de encapsular o PDU.

Ingress PE Router

•      O PE de entrada recebe o PDU e remove o preamble, o delimitador do frame (SFD), e o frame check sequence (FCS). O resto do cabeçalho permanece o mesmo.
•      O PE copia o codigo de controle do cabeçalho, mesmo que não seja usado, adiciona um label VC e um label do túnel LSP para o roteamento normal do MPLS através do backbone. A rede roteia os dados usando o tunnel LSP convencional do MPLS sem distinguir o tipo de tráfego.

Egress PE Router

•      O PE de destino recebe o pacote e remote o label do LSP, caso exista (Penultimo geralmente retira), retira o label de controle e o label do VOCÊ;
•      O PE atualiza o cabeçalho se necessário e envia o pacote para o CE associado.


Objetivo

Cinco roteadores (CE1, PE1, P, PE2 e CE2) são conectados formando um backbone com 3 roteadores e dois CEs conectados. Pede-se:
•      O protocolo de roteamento de backbone PE1-P-PE2 deverá ser o OSPF na área 0 com todas as interfaces divulgadas e com LDP entre os PEs para tráfego MPLS;
•      O CE1 e o CE2 e deverão se comunicar via o backbone usando túnel AToM.

Topologia

IOS utilizados

• CE1, PE1, P, PE2 e CE2 – c7200-k91p-mz.122-25.S15.bin

Configuração dos Roteadores

Configurações do OSPF do Backbone

Em todos os roteadores configura-se o roteamento OSPF pelo comando “router ospf ” onde o “processo” é um numero do processo OSPF. O roteador também possui um router ID único que geralmente é a interface loopback ou então o maior endereço IP do roteador.
Para adicionar interfaces deve-se usar o comando “network

área

”. Um roteador pode ter interfaces em áreas distintas, define-se cada área pelo comando network e o tipo da área com o comando “area [type]”.

Configurações do MPLS

Antes de qualquer configuração, o Cisco Express forwarding deve ser habilitado com o comando “ip cef”. Para habilitar o MPLS no modo LDP, usa-se o comando global “mpls label protocol ldp”.
Para habilitar o MPLS nas interfaces, configura-se “mpls ip”.

Configuração do Túnel AToM

O tunnel L2 AToM é configurado na interface do PE conectada diretamente ao CE com o comando “xconnect encapsulation mpls”. O ID do VOCÊ tem que ser o mesmo nos dois PEs.
Para interface em trunk, deve-se configurar o trunk na interface do PE.

Observações e Bugs

 

Configuração

 

CE1

 

!
interface FastEthernet1/0.10
 encapsulation dot1Q 10
 ip address 10.10.10.1 255.255.255.0
!

 

 PE1

 

!
ip cef
!
mpls label protocol ldp
!
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet1/0.10
 encapsulation dot1Q 10
 xconnect 2.2.2.2 100 encapsulation mpls
!
interface FastEthernet2/0
 ip address 13.13.13.1 255.255.255.0
 mpls ip
!
router ospf 1
 router-id 1.1.1.1
 network 1.1.1.1 0.0.0.0 area 0
 network 13.13.13.1 0.0.0.0 area 0
!

 

 

P

 

!
ip cef
!
mpls label protocol ldp
!
!
interface Loopback0
 ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet1/0
 ip address 13.13.13.3 255.255.255.0
 mpls ip
!
interface FastEthernet2/0
 ip address 23.23.23.3 255.255.255.0
 mpls ip
!
router ospf 1
 router-id 3.3.3.3
 network 3.3.3.3 0.0.0.0 area 0
 network 13.13.13.3 0.0.0.0 area 0
 network 23.23.23.3 0.0.0.0 area 0
!

 

 PE2

 

!
ip cef
!
mpls label protocol ldp
!
!
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet1/0.10
 encapsulation dot1Q 10
 xconnect 1.1.1.1 100 encapsulation mpls
!
interface FastEthernet2/0
 ip address 23.23.23.2 255.255.255.0
 mpls ip
!
router ospf 1
 router-id 2.2.2.2
 network 2.2.2.2 0.0.0.0 area 0
 network 23.23.23.2 0.0.0.0 area 0
!

 

CE2

 

!
interface FastEthernet1/0.10
 encapsulation dot1Q 10
 ip address 20.20.20.1 255.255.255.0
!
Fonte: http://babarata.blogspot.com.br/2013/04/v-behaviorurldefaultvmlo_30.html

Suporte a VLAN Trunk em Servidores Linux

redhat_tux
Segue um post de um blog que sigo e tem muita coisa boa também, tem foco cisco mas também várias infos linux, se você como eu segregou sua rede interna com voz/dados/cameras etc essa dica vai te ajudar no dia dia 🙂
Tradicionalmente utilizamos switches multi-layer ou roteadores quando precisamos fazer o roteamento inter-VLAN em ambientes que possuem múltiplas VLANs associadas com suas respectivas sub-redes, uma vez que essas caixas especializadas oferecem suporte nativo ao encapsulamento 802.1q (trunk). Em um dos artigos mais lidos do blog, intitulado “Configuração de Switch Multi-Layer”, explico ao leitor como configurar um switch Cisco para essa finalidade, através da criação de interfaces virtuais vinculadas às suas VLANs, de maneira que essas interfaces podem ser configuradas com um IP que será o gateway de todas as máquinas membros da respectiva VLAN.

Essa mesma tarefa pode ser configurada em um servidor Linux, por isso a topologia apresentada abaixo será utilizada para exemplificar o processo de configuração de roteamento inter-VLAN no Linux. Assim como nos artigos anteriores, estou considerando que o roteador Linux está instalado com a distribuição Debian GNU/Linux (ou seus derivados, como o Ubuntu).

A primeira etapa consiste na instalação do pacote denominado vlan para que, posteriormente, as configurações de rede do Linux ofereçam suporte à criação de interfaces lógicas roteadas (layer-3) do tipo VLAN. Essa tarefa é simples e rápida através do APT:

apt-get install vlan

Agora basta editar o arquivo de configuração das interfaces de rede que fica localizado em “/etc/network/interfaces”. A partir da interface física eth0 (trunk 802.1q), criaremos duas novas interfaces lógicas denominadas eth0.100 (vlan100) e eth0.200 (vlan200).

###— em /etc/network/interfaces

auto eth0
iface eth0 inet manual

   auto eth0.100
   iface eth0.100 inet static
      address 192.168.100.254
      netmask 255.255.255.0

   auto eth0.200
   iface eth0.200 inet static
      address 192.168.200.254
      netmask 255.255.255.0

Na sintaxe eth0.100 fazemos referência à interface física antes do ponto e, depois do ponto, fazemos referência ao número da VLAN vinculada à interface. É somente depois da instalação do pacote vlan que o Linux passa a reconhecer essa sintaxe. Uma alternativa válida seria utilizar uma convenção diferente de nomes em que fazemos referência direta à VLAN na denominação da interface em conjunto com o parâmetro vlan-raw-device para associá-la a sua respectiva VLAN. O exemplo abaixo traz a mesma configuração anterior com essa sintaxe alternativa:

###— em /etc/network/interfaces

auto eth0
iface eth0 inet manual

auto vlan100
iface vlan100 inet static
   vlan-raw-device eth0
   address 192.168.100.254
   netmask 255.255.255.0

auto vlan200
iface vlan200 inet static
   vlan-raw-device eth0
   address 192.168.200.254
   netmask 255.255.255.0

Como o Linux não permite o roteamento entre sub-redes por padrão, é necessário instruir seu kernel a fazê-lo por meio de um dos comandos abaixos, lembrando que a primeira opção é volátil, ou seja, será perdida em caso de boot, enquanto que a segunda opção é persistente:

opção 1) echo “1” > /proc/sys/net/ipv4/ip_forward
opção 2) sysctl -w net.ipv4.ip_forward=1

Obs.: Vale ressaltar que as interfaces lógicas do tipo VLAN são diferentes das tradicionais sub-interfaces lógicas vinculadas às interfaces físicas. A criação de sub-interfaces lógicas é uma técnica simples de virtualização de interfaces físicas nativamente reconhecida pelo Linux, procedimento realizado através da sintaxe ethX:X. Por outro lado, o Linux torna-se capaz de interpretar cabeçalhos 802.1q (trunk) quando utilizamos o pacote vlan para criar interfaces lógicas roteadas do tipo VLAN (sintaxe ethX.X).

Façam seus testes…
Samuel.
Fonte: http://labcisco.blogspot.com.br/2015/07/suporte-vlan-trunk-em-servidores-linux.html